久而旧之

laravel5.5快速入门 —— 安装配置篇

2017-09-15

一、服务器要求

Laravel 框架对PHP版本和扩展有一定要求,不过这些要求 Homestead 都已经满足了,不过如果你没有使用 Homestead 的话(那真是一件很遗憾的事情),有必要了解下这些以便确认自己的环境满足要求:

  • PHP >= 7.0.0
  • PHP OpenSSL 扩展
  • PHP PDO 扩展
  • PHP Mbstring 扩展
  • PHP Tokenizer 扩展
  • PHP XML 扩展

满足以上需求之后,就可以开始安装 Laravel 了。

二、安装 Laravel

Laravel 使用 [ Composer ] 管理依赖,所以,安装之前确保已经在机器上安装了 Composer。

  • PHP >= 7.0.0
  • PHP OpenSSL 扩展
  • PHP PDO 扩展
  • PHP Mbstring 扩展
  • PHP Tokenizer 扩展
  • PHP XML 扩展

满足以上需求之后,就可以开始安装 Laravel 了。

通过 Laravel 安装器

首先,通过 Composer 安装 Laravel 安装器:

composer global require “laravel/installer”

确保 $HOME/.composer/vendor/bin 在系统路径中

安装完成后,通过简单的 laravel new 命令即可在当前目录下创建一个新的 Laravel 应用,例如,laravel new blog 将会创建一个名为 blog 的新应用,且包含所有 Laravel 依赖。该安装方法比通过 Composer 安装要快很多:

laravel new blog

如果之前已经安装过旧版本的 Laravel 安装器,需要更新后才能安装最新的 Laravel 5.5 框架应用:

composer global update

通过 Composer Create-Project
你还可以在终端中通过 Composer 的 create-project 命令来安装 Laravel 应用:

composer create-project –prefer-dist laravel/laravel blog


  • Notice

如若需要 请戳 <a href=’https://shunhua.github.io/about/'target="_blank">[ About ] 下联系我 欢迎联系.ok,enjoy it !

使用支付宝打赏
使用微信打赏

欢迎点击上方按钮对我打赏,谢谢你给我吃糖果